Print Page | Close Window

zGlossary examples not working in all browser

Printed From: Zazar
Category: Zazar
Forum Name: Problem Reports
Forum Description: A forum for submitting problem reports. Only one problem per thread.
Printed Date: 15 Aug 2018 at 19:13
Software Version: Web Wiz Forums 10.15 -

Topic: zGlossary examples not working in all browser
Posted By: armyofda12mnkeys
Subject: zGlossary examples not working in all browser
Date Posted: 05 Sep 2013 at 14:23
I was looking at the examples pages and none of them work (in Chrome, Firefox21.0, or IE9)...

For example:
Only shows the standard title attribute hover popup and not the styled hover.

Posted By: David
Date Posted: 06 Sep 2013 at 15:13

You need to click the link that is added to the term to show the definition popup.

David Woolston
Zazar Support

Posted By: starkey
Date Posted: 06 Dec 2013 at 01:52
Thank you for making the zGlossary plugin available.

I downloaded the zGlossary files from this page with a hope that I can run it in my own dev site. But I am having issues in making the in-page popup show up on test pages such as example.html or the other html pages.

Debugging the test page using chrome get me some error message: "Failed to load resource: the server responded with a status of 404 (Not Found)" i.e. referring to the “terms.json” file.

Could you please help?

Posted By: David
Date Posted: 06 Dec 2013 at 09:28

This plugin is based on server technology it must be run via a web server either hosted or locally on a development computer.

David Woolston
Zazar Support

Posted By: starkey
Date Posted: 06 Dec 2013 at 18:05
Hi David,

Thank you for the pointer.

I managed to resolve the issue by adding a new MIMIE type on IIS.

I basically opened up IIS and added new MIMIE type with the following entries:
File name extension = json
MIME type = application/json

Once again thank you for the script.

Posted By: starkey
Date Posted: 07 Dec 2013 at 01:08
One question leading to another. I have the following json entry:
"definition":"Asian Institute of Technology"

The problem is, if I have a statement in my web page saying that
"you will need to wait to be notified by us about your application". Then what happens is the word wait will be identified as a definition term because of the ait part.

Is there a way where I can exclude such types of words. For your information I tried the example_exclude.html file whereby I added wait as one of the terms to get excluded but it didn't work.
excludetags: ['h1', 'h2', 'a', 'wait']

Any suggestion will be appreciated.

Posted By: David
Date Posted: 09 Dec 2013 at 11:43

Have you tried putting a space before the word ie " ait". I'm currently looking into a "complete word" option that would resolve your issue and also take into account possible suffixes like .,(){} etc

David Woolston
Zazar Support

Posted By: smith
Date Posted: 09 Dec 2016 at 10:05
I am new in this forum. i am very glad to join that. thanks for sharing that thread with us." rel="nofollow - News in India, Breaking News

Print Page | Close Window

Forum Software by Web Wiz Forums® version 10.15 -
Copyright ©2001-2013 Web Wiz Ltd. -